ubuntu14.04にmikutterをインストールしてみた

mikutterというtwitterクライアントがあることを知ったので、お試しでインストールしてみました。
落としてきたtarballから見てバージョンは3.2.0です。

README

全てのミク廃、そしてTwitter中毒者へ贈る、至高のTwitter Clientを目指すTwitter Client。
略して至高のTwitter Client。

ということだそうです(引用)。ごめんなさい、あんまりミク知らない。
動作要件をかいつまむと以下のような感じらしい。

  • ruby (2.0 – 2.1.5)
  • ruby gtk (2.2.3)
  • rcairo (1.12.9)
  • Open SSL

ruby..

ruby関連のインストール

こういうのはrbenvでやるのがいいのかもしれませんが、
rbenvで2.1を入れようとしたらOpenSSLのエラーが出て気力が削がれたためやめました。
こちらでubuntuからでもruby2系を入れられることがわかったので試してみました。

# PPAの登録
$ sudo add-apt-repository -y ppa:brightbox/ruby-ng
$ sudo apt-get update
 
# ruby2.1のインストール
$ sudo apt-get -y install ruby2.1 ruby2.1-dev
# bundlerのインストール
$ sudo gem2.1 install bundler

mikutterの動作に必要なライブラリのインストール

# 適当な場所にtarballを置いて解凍&移動
$ tar fxz mikutter.3.2.0.tar.gz
$ cd mikutter
# Gemfileのインストール
$ sudo bundle install

起動

「ruby2.1 mikutter.rb」とすると
mikutter_installed

起動しました。
おわり